AMH支持php5.2.17p1 解决方案

AMH支持php5.2.17p1 解决方案

PHP官方早已放弃php5.2版本,停止维护、更新已有好多年了。
但国内还有一些老程序停留在php5.2环境,前段时间也做了一系列投票调查、与收集用户反馈,
最近多用户模块首个版本也基本完成,最后还是决定提供php5.2版本运行支持,
但是同样,除特殊情况外AMH也不再会提供php5.2版本任何更新与维护。
在用php5.2版本的用户应该尽早转到php5.3或更高版本、以更好安全稳定运行。

1、AMH安装PHP-5.2.17p1

安装PHP-5.2.17p1,php5.2与php5.3共存、同时运行:
wget http://code.amysql.com/files/php-5.2.sh;
chmod 775 php-5.2.sh;
./php-5.2.sh;

2、虚拟主机切换至php5.2版本

1) 面板上安装AMChroot-1.1模块,切换相应虚拟主机至兼容模式。
2) 切换虚拟主机至php5.2版本:
/usr/local/php-5.2/php52 PHP版本号 主标识域名

使用例子,切换虚拟主机amysql.com。
php5.2版本:
/usr/local/php-5.2/php52 php-5.2 amysql.com

php5.3或其它版本:
/usr/local/php-5.2/php52 php-5.3 amysql.com

3、使用知识小提示
1) php5.2安装目录:
/usr/local/php-5.2

2) php5.2版本 php.ini 与 php-fpm 配置位置:
/usr/local/php-5.2/etc
可以对默认配置进行更改。

3) 同样可以使用 /etc/init.d/amh-start
进行重启面板与php5.2。

4) 如果已切换使用php5.2,
可以在面板停止相应站点的php运行(面板是php5.3),减少不必要开销。

相关新闻

联系我们

17896009363

在线咨询:点击这里给我发消息

邮件:huangjie@kouer.com

工作时间:周一至周五,9:30-18:30,节假日休息