解决WordPress升级版本及安装插件出现”Problem with the SSL CA cert”

帮助一个同学的WordPress博客从虚拟主机搬迁到VPS主机环境中,他的VPS环境是采用的免费版AMH4.2环境搭建的,告知在升级最新WordPress4.3版本以及安装插件的时候无法下载,有提示Problem with the SSL CA cert (path? access rights?)错误,这个问题老左也还是第一次遇到。
解决WordPress升级版本及安装插件出现”Problem with the SSL CA cert”
这个问题如果不能解决,那所有以后的升级主题、插件安装,得全部采用手工升级和激活,还是比较麻烦的,于是发挥搜索功能,找到解决方法。这个问题主要是系统的安全导致的限制,我们可以在AMH面板后台安装和开启AMChroot模块,然后把默认的安全模式设置成兼容模式。
解决方法:
第一、下载和安装AMChroot 模块
下载和安装AMChroot 模块
从AMH模块后台下载激活AMChroot 模块。
第二、设置兼容模式
设置兼容模式
这里设置兼容模式。
最后,我们在升级版本,或者在线下载安装插件,是没有问题的,鉴于安全考虑,我们在升级完毕之后还需要将AMChroot 模块设置回到安全模式。同样的,在非AMH面板模式下,老左也有看到其他环境也有出现这样的问题,老外的文章有提到解决方法,是重启整个服务器,然后可以解决这个问题,具体我还没有遇到过,所以只是看到有这样的文字解决方法,如果有遇到的可以试试。

「点点赞赏,手留余香」

    还没有人赞赏,快来当第一个赞赏的人吧!